Teilen Sie Ihre Erfahrunge und Wünsche mit uns und anderen Usern!

0
Wird überprüft

Reading many inputs

Willem Van Der Gaag vor 2 Tagen in Game4Automation Starter and Professional aktualisiert von Thomas vor 2 Tagen 1

Hi! Is it possible to acces all the inputs at the same time. I would like to write all the values of these to a file for future reference. Thanks in advance!

Antwort
Thomas vor 2 Tagen

You could loop through all Signal objects in a script each FixedUpdate and read Signal.Value for saving it to whatever format you would like.

0
Beantwortet

Is it possible to make an executable game-file linked to PLC?

Toni Niemi vor 2 Wochen in Game4Automation Starter and Professional aktualisiert von Thomas vor 2 Wochen 5

Hey! 

I have managed to get the OPC UA -connection working with while inside Unity Editor's Play-mode, but when I try to Build into an .exe, the OPC UA -connection no more works. Is there a solution to this?

Antwort
Thomas vor 2 Wochen

The Upgrade Message is always there - if you can use and add OPCUA and other Professional features you are having the professional version. Will let you know when the Beta is available. B

0
Beantwortet

Is it possible to write to a Bool in DB with S7. e.g. PLCInputBool to DB43.DB145.0

Neil vor 3 Wochen in Game4Automation Starter and Professional aktualisiert vor 3 Wochen 2

Hello. I'm thinking it isn't possible to write to a Bool in DB, but maybe I haven't tried the right format. Any tips? Thanks.

Antwort
Thomas vor 3 Wochen

Hello,

writing to DBs is described here and it should be possible what you like to do:

https://game4automation.com/documentation/current/s7tcpip.html#Reading-and-Writing-DBs


I think it should be DB43.DBX145.0


0
Not a bug

g4a duplicates Script

Benedikt Scholz vor 4 Wochen in Game4Automation Starter and Professional aktualisiert von Thomas vor 4 Wochen 1

I am building some UI Elements to write PLCOutputFloats (bool, etc) from Input fields, toggles and buttons. 

Spontaneously I am getting errors because of ambigious names for these PLCOutput classes. 

Somehow g4a duplicates the classes so I get a PLCOutputBool1.cs

Can you explain what´s wrong?

Best regards

Benedikt

Antwort
Thomas vor 4 Wochen

G4A itself for sure not duplicates classes. Currently I don't know why this happens. Please delete the duplicated classes.

0

Import problem with Pixyz

The Import and update with the Pixyz Plugin does not work since updating to Unity 2019. The workaround you, Thomas, explained to me does not work. I can´t compare the Current and Update. The Problem is that the JT_Prop_Name does not appear in the Metada of the CAD-File. I get an error ".....is not unambigious". The Updater does not detect that the CAD-File changed during update. 

Pixyz said the plugins API will work with the next update which is going to be released around the end of February. 

Can you put that on your issue list so that it will work as soon as possible? The Updater is very important for us.

0
Wird überprüft

Sensor "Limit Sensor To Tag" null Error

DAT vor 1 Monat in Game4Automation Starter and Professional aktualisiert von Thomas vor 1 Monat 2

I have encountered a few error from sensor script:

The sensor script throws a null error when using the "Limit Sensor To Tag" function unless the parent object have a MU.

Even though I am using the "Limit Sensor To Tag" function the sensor still gets trigger by the parents objects of the object that have the tag. (Parents objects do have mesh collider attached)

Antwort
Thomas vor 1 Monat

Hi Dat, I just checked. Objects wich are colliding with the Sensor must alway have the MU script on the same or in a level above the collider. This is the planned behaviour. I don't know in what combinatione exactly your problem comes up. Can you send me a simple example?

0
Beantwortet

Unity Build Player Window error

Denis vor 2 Monaten in Game4Automation Starter and Professional aktualisiert von Thomas vor 1 Monat 8

Hello , I have errors when i trying to build player window , its works when i delete game4automation , and if i add game4automation and trying to compile i get some errors , I want to mention that I did not add the s7 interface, I did not add anything

Antwort
Thomas vor 1 Monat

Problem was solved by deleting Parts4Cad and Zip in Tools. Included ZIP is not compatible with UWP. We will change that in future.

0
Beantwortet

S7 plc i want to show on scene value from the controller

Denis vor 2 Monaten in Game4Automation Starter and Professional aktualisiert vor 2 Monaten 4

Hello , i want to show value from the controler as a text on scene , how i can do that?

Antwort
Thomas vor 2 Monaten

Hello,

you need to do it with a little script that takes Signal.Value and which is putting this into a Unity UI text box.

0
Wird überprüft

S7 interface plc input write error CPU : Function not available

JO SG vor 3 Monaten in Game4Automation Starter and Professional aktualisiert von Thomas vor 3 Monaten 6

Helo. Im trying to connect s7-1200 with game4automation. I saw the tutorial video and the https://game4automation.com/documentation/current/s7tcpip.html.

I followed all the process but still not working with this signs keep cycling.

I successfully checked the connection and added sdf file as well.

S7 interface plc input write error CPU : Function not available

I don't know how to solve this problem. Thank you.

Antwort
Thomas vor 3 Monaten

Hi, sorry for my late response. We needed first to support the open issues of our professional customers.

I checked your project but it seems that I don't have all data to be able to reproduce your problem. I would need your full S7 project. And you need to tell me which scene to open and what else to do to get the same problems as you do. Thanks.

0
Wird überprüft

Error opening game4automation project in a different PC

looi vor 4 Monaten in Game4Automation Starter and Professional aktualisiert von Thomas vor 3 Monaten 5

I've started a project with the game4automation asset. I have a robot connected with the roboDK interface. When I try to open the project with another PC, It appears this error:

ArgumentNullException: Value cannot be null.
Parameter name: String
System.Number.StringToNumber (System.String str, System.Globalization.NumberStyles options, System.Number+NumberBuffer& number, System.Globalization.NumberFormatInfo info, System.Boolean parseDecimal) (at <9577ac7a62ef43179789031239ba8798>:0)
System.Number.ParseInt32 (System.String s, System.Globalization.NumberStyles style, System.Globalization.NumberFormatInfo info) (at <9577ac7a62ef43179789031239ba8798>:0)
System.Int32.Parse (System.String s) (at <9577ac7a62ef43179789031239ba8798>:0)
game4automation.PLCOutputInt.SetValue (System.String value) (at [old PC Path]/PLCOutputInt.cs:58)
game4automation.RoboDKInterface.UpdateSignals () (at [old PC Path]/RoboDK/RoboDKInterface.cs:320)
game4automation.RoboDKInterface.CommunicationThreadUpdate () (at [old PC Path]/RoboDK/RoboDKInterface.cs:537)
game4automation.InterfaceThreadedBaseClass.CommunicationThread () (at [old PC Path]/InterfaceThreadedBaseClass.cs:50)
System.Threading.ThreadHelper.ThreadStart_Context (System.Object state) (at <9577ac7a62ef43179789031239ba8798>:0)
System.Threading.ExecutionContext.RunInternal (System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, System.Object state, System.Boolean preserveSyncCtx) (at <9577ac7a62ef43179789031239ba8798>:0)
System.Threading.ExecutionContext.Run (System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, System.Object state, System.Boolean preserveSyncCtx) (at <9577ac7a62ef43179789031239ba8798>:0)
System.Threading.ExecutionContext.Run (System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, System.Object state) (at <9577ac7a62ef43179789031239ba8798>:0)
System.Threading.ThreadHelper.ThreadStart () (at <9577ac7a62ef43179789031239ba8798>:0)
UnityEngine.<>c:b__0_0(Object, UnhandledExceptionEventArgs)

It seems like some paths from the old PC are still remembered by the asset. I have changed the RoboDK Application path and the RoboDK file path, but the error stays. Reinstalling the asset just works, but it is uncomfortable to do it every time I switch to another PC.

Antwort
Thomas vor 3 Monaten

If you changed the RoboDK pathes I don't know why it not opens. The code is always just using this path. Is your path somehow uncommon with special characters or empty spaces?

You might need to set some breakpoints in RoboDKInterface.cs and check what is going wrong. If you don't find the issue we should do a Zoom Session and I will check on your computer.