Teilen Sie Ihre Erfahrunge und Wünsche mit uns und anderen Usern!

Answer
Support 3 days ago

Can you turn  in the OPCUA interface  the DebugMode to true and send us the content of the console log?

+1
Completed

OPCUA Interface - Error in activating session

Ernesto 2 months ago in OPCUA4Unity updated by maokeuncle 4 days ago 10

Dear all,

I'm having problems to connect to a remote OPC UA server using the OPCUA Interface Component.

I followed the "Connection troubleshouting" guidelines provided in "/game4automation/Documentation/opcua.html".

Configuring the OPC Server with "No security certificates and passwords" I could connect OPC Watch with the server (see Image):



However, when I tried connecting through the Unity OPCUA Interface:



I get the following error message:

OPCUA Interface - Error in activating session [BadUnknownResponse]
UnityEngine.Debug:LogError (object)
game4automation.OPCUA_Interface:Connect () (at Assets/game4automation/private/Interfaces/OPCUA4Unity/OPCUA_Interface.cs:179)
game4automation.OPCUA_Interface:EditorImportNodes () (at Assets/game4automation/private/Interfaces/OPCUA4Unity/OPCUA_Interface.cs:246)
game4automation.OPCUAInterfaceEditor:OnInspectorGUI () (at Assets/game4automation/private/Interfaces/OPCUA4Unity/private/Editor/OPCUAInterfaceEditor.cs:20)
UnityEngine.GUIUtility:ProcessEvent (int,intptr,bool&)


As it can be seen in the last image, I'm using Unity 2021.3.2f1 Editor with Game4Automation Digital Twin Professional 2020.


Any idea of what I'm missing?


Thank you in advanced.

Answer
Support 5 days ago

Hi Erenesto,

I am sending you an email with a new code for OPCUA_Interface.cs. Please replace yours with this new code and I hope connection will work.

Changes will be included in upcoming 2021 release.

+1
Answered

Robodk version with game4automation professional or game4automation OPC UA

efrensilveyra 1 year ago in OPCUA4Unity updated by Support 1 year ago 1

Which version of robodk is compatible with game4automation opc ua or game4automation professional. I ask, because I want to communicate robodk 4.0 with game4automation professional.

+1
Answered

When will Unity 2019 be supported?

Stan 2 years ago in OPCUA4Unity updated by Support 2 years ago 5

Hello,


I was wondering when will OPC UA for Unity 2019 will be supported?

With kind regards,

Stan (Developer at Siemens)

Answer
Support 2 years ago

Hi, we have no tutorial about that.Even if Unity 2019 is not officially supported yet, you should be able to get it running. What is your problem. What kind of error messages do you have?

0
Answered

First person and orbit controls problem

wujustin809 3 days ago in realvirtual.io Starter and Professional updated by Support 4 hours ago 2

Hey team! I just had a quick question regarding the cameras in the game4automation demo scene. 


I am trying to turn on the first person camera provided to us but unfortunately it is not working properly. What I want is the user to be able to walk around the game4automation scene in first person view and also have the full functionality of the normal orbit controls the scene currently has. May you please give me some instructions on how to do this? There seems to be no documentation about this. If the above is not possible, how can one turn on the first person controls and once a camera is clicked such as 1 or 2, orbit controls are turned on while first person is turned off. Then there needs to be an option to turn first person controls back on again. This is taking me much longer than it should where I believe it should be a simple fix on my end so I truly appreciate the help. Thank you in advance!

Answer
Support 4 hours ago

1) We did not planned to support jumps. You could build your own logic by changing Assets/game4automation/private/RuntimeUI/FirstPersonController.cs

2) You could use this function and your own custom script for doing this:

https://docs.unity3d.com/ScriptReference/MonoBehaviour.OnMouseDown.html

0
Answered

Allen‑Bradley, Rockwell PLC Framework

kkellner 1 week ago updated by Support 1 week ago 3

Gibt es nativ eine direkte Schnittstelle zum Rockwell PLC Framework?

Ich konnte keine explizierte Erwähnung (wie für Siemens oder Beckhoff)

finden.

Answer
Support 1 week ago

All of them have the basic function of signal exchange with the PLC. The functionality essentially depends on what the interface to the PLC of the manufacturer enables.

The most comprehensive - including signal import via the interface - is the TwinCAT ADS interface.

With S7, the signals must be exported from Step7 via a standardized text file and imported into G4A.

With EthernetIP there is no standard for this. The signals must be created manually or imported via a non-standard text file.


0
Answered

Post Processing error when Integrating third party asset with game4automation

mahetajr 2 weeks ago in General Questions updated by Support 2 weeks ago 1

I have been facing a problem importing the game4automation asset (https://assetstore.unity.com/packages/tools/utilities/game4automation-digital-twin-starter-2020-139866#description) into a scene I made using an asset called CityGen3D (https://assetstore.unity.com/packages/tools/terrain/citygen3d-162468#description).

When I create a blank new project and use the game4automation asset without my own scene, it works perfectly fine. However, when I try importing the asset into my scene, I keep encountering a 'PostProcessing' error. If I double click on the error, it leads me to the code that contains some stuff about postprocessing (see second image attached). I am not sure what is causing this. May you be able to provide me some assistance? Please see attached images for the error.

Answer
Support 2 weeks ago

Hi,


because your additional assets in the project are using Unity Postprocessing you need to put this into the Game4Automation.base Assembly definitions:


There is also some information about this here in the documentation:

https://game4automation.com/documentation/current/game4automation.html

0
Answered

Problems in OPCUA4Unity Output

Janik Tian 4 weeks ago in OPCUA4Unity updated by Support 3 days ago 4

Servus, I'm using OPAUA Interface for my first Program, but there are some problems with communication when i write int and float format variables in my PLCs.  In Figure 3 and 4 I try to write INT values to "robotArmSuccess" but in OPC Server the corresponding values are not changed. Then I read Demo of OPCUA and modify my Program with the function WriteNodeValue(NodeId, value) , it did not work in PLC Server, according to figure 1 and 2 . Could you please give me some Guidance for this situation?  

Figure 1

Figure 2

Figure 3

Figure 4

0
Answered

Dies ist eine Frage zur Änderung der Farbe des Konveyor-Teils.

Mr Jin 1 month ago in realvirtual.io Starter and Professional updated by Support 4 weeks ago 4

Hallo. Ich benutze Game4Automation Simulation gut. Ich möchte wissen, wie man die Farbe eines Conveyor-Teils ändern kann.

Answer
Support 4 weeks ago

You just need to drag and drop a material with the wished color on the mesh of the frame.

0
Answered

Driver_Simple script does not accept OPC UA variable nodes

Ernesto 1 month ago in OPCUA4Unity updated 6 days ago 12

Dear developers,

I was trying to connect a custom Game4Automation Scene to a PLC through OPCUA Interface.


I followed the instructions from this tutorial:


The OPCUAInterface is updating the nodes correctly:


However, when I tried to link a bool variable node from the OPCUAInterface to the Driver_Simple interface dragging it and droping it into the forward variable, it wasn't accepted (the forbiden symbol appeared).

If I use the PLC signal component I'm able to link the component without problems.

I'm using Unity 2021.3.2f1 Editor and the game4automation-Professional-2019.13 package (OPCUAInterface is not working in the latest version of G4A, see https://forum.game4automation.com/en/communities/1/topics/376-opcua-interface-error-in-activating-session).

Any idea of what am I doing wrong?

Thank you in advance!

Answer
Support 1 month ago

Sorry I missed it.There also needs to be GAME4AUTOMATION in the compiler defines.

Apply standard settings should do the job. 


Normally this is called upon first installation. What kind of products do you have got. Did you had any compiler errors when first installing Game4Automation Asset.


If there are compiler errors directly after installagion e.g. by some naming collissions with other things, that are also in the project, it might happen that the standard settings are not set as wished.