0
Fixed

Problem with rotational drive in combination with prismatic drive

PeterFischer vor 4 Wochen in Game4Automation Starter and Professional aktualisiert vor 4 Wochen 4

Hello,

I noticed a problem with the motion axis feature in G4A. I created some sort of articulated arm which rotates around the vertical y-axis using a Drive script and a Drive_FollowPosition script. This works fine, however problems occur when I add a linear (prismatic) drive in a child object of it. I added a video to make it more clear: As you can see there is Link1 which rotates and Link2 (green) which contains a drive script with the direction "Linear Z". Since Link2 doesn't have any Drive Behaviour script yet, it shouldn't move at all, but as you can see, it starts drifting away. This problem doesn't occur when only rotational joints are used in the kinematic chain. Is it possible to fix somehow?

g4a_drive.mp4

Antwort

Antwort

Hi, 

you need to change this line (left = old, right = new) in the Drive script:

It will be changed in Release 1.024 (Build 246 and upwards).

For customers who wish a Beta download - please send us your Invoice Number and we can send you a download link!

Wird überprüft

I will check this tomorrow. For sure we will be able to fix it!

Antwort

Hi, 

you need to change this line (left = old, right = new) in the Drive script:

It will be changed in Release 1.024 (Build 246 and upwards).

For customers who wish a Beta download - please send us your Invoice Number and we can send you a download link!