0
Beantwortet

Problems importing into a project

leevi.parssinen vor 12 Monaten in Game4Automation Starter and Professional aktualisiert von Thomas vor 12 Monaten 2

Hi!

So my problem is that when i try to import the asset package into my existing project, it will import it but the Game4Automation tab will only have the Part4Cad in it. Also tried to make a new project by adding the asset first and then exporting and importing my old project, but this had the problem that colliders won't work anymore.

And one more question! (sorry I'm new to unity)

I can get the signals from my TwinCat via ADS, but how do you link the imported signals for example to a game objects Y-axis value?

Hopefully you could help me!

Antwort

Antwort
Beantwortet

For anyone experiencing similar issues.

Problem was that the compile settings were not set correctly:

https://game4automation.com/documentation/current/compilerdefines.html

, that collision layers were not set correctly:

https://game4automation.com/documentation/current/physics.html

and that Prostprocessing was not included in the Assembly Definitions:

https://game4automation.com/documentation/current/game4automation.html

https://game4automation.com/documentation/current/assemblydefinitions.html

Wird überprüft

Hi Leevi,

please check the Youtube Video about TwinCAT. This should show you how to connect it.


It is hard to say what the problem is based on your description. If you send me your existing project I could check where the problem is. I will send you a link via email to upload.

It seems, that you need some basic Unity training. You could also purchase a support package and I will help you and train you via Zoom / Skype.

Best regards

Thomas

Antwort
Beantwortet

For anyone experiencing similar issues.

Problem was that the compile settings were not set correctly:

https://game4automation.com/documentation/current/compilerdefines.html

, that collision layers were not set correctly:

https://game4automation.com/documentation/current/physics.html

and that Prostprocessing was not included in the Assembly Definitions:

https://game4automation.com/documentation/current/game4automation.html

https://game4automation.com/documentation/current/assemblydefinitions.html