0
Fixed

VFX Graph error after importing Game4Automation in 2020.1 project

khr vor 3 Monaten in General Questions aktualisiert von Thomas vor 4 Wochen 19

H. I have recently imported Game4Automation into my project, but has since not been able to compile. 
The console throws me a 
InvalidEnumArgumentException in visualeffectgraph's Orient.cs

Has anyone run into this?

Antwort

Antwort

Please share with me the blank project. Thanks!

Not a bug

Hi,

Game4Automation is only supporting the last Unity LTS (Long Term Stable) Release which is currently 2019.4....

You might get it work with 2020.... but I am sorry, that we can't support this. But generally, it is not a big issue to get it running with a newer version.

2020 will be supported when the 2020 LTS is released which is about 1st quarter of 2021.

Best regards

Thomas

Hi Thomas. Thank you for your reply. Unfortunately i have just created a 2019.4 LTS project and added Game4Automation, yet i still get exactly the error.



Library\PackageCache\com.unity.visualeffectgraph@7.3.1\Editor\Models\Blocks\Implementations\Orientation\Orient.cs(262,31): error CS0433: The type 'InvalidEnumArgumentException' exists in both 'System.Private.ServiceModel, Version=4.1.1.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' and 'System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'

This error does not seem to be directly related to game4automation. Did you import game4automation into an empty project? Are in your project already any packages included?

Yes. I created a 2019.4 LTS based project, and imported Game4Automation Package. The error pursued.
The projects are HDRP based. Is that a problem?

We will check with HDRP!

The OPCUA interface seems not to be compatible with the HDRP render pipeline. If you delete the folder OPCUA4Unity game4automation should work. But all demo models are built for the default Render Pipeline.

The reason is the System.Private.ServiceModel.dll which is needed for the OPCUA dll.

I have no short term workaround for this and I hope that you don't need OPCUA in your HDRP project.

We are working on the next Update of our OPCUA interface which should be Hololens2 compatible. We will try to solve in this update also the HDRP issue for OPCUA but it might take some weeks.

Alright. Great that you found the issue. I take it that URP is not supported either then?

No URP seems to work. But the same issue with demo scenes - they are build based on the default render pipeline.

Do you need OPCUA and HDRP in your project?

Alright, i will go with URP then. HDRP will be important at some point, but i can wait weeks for the support, and just go with URP for now, as OPCUA is a necessity for me.

Furhter investigation shows that deleting OPCUA4UNITY folder gets rid of the problem, so the issue must lie there

Hi,
I am also facing the same issue "Library\PackageCache\com.unity.visualeffectgraph@7.4.3\Editor\Models\Blocks\Implementations\Orientation\Orient.cs(338,31): error CS0433: The type 'InvalidEnumArgumentException' exists in both 'System.Private.ServiceModel, Version=4.1.1.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' and 'System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'

My project runs in Unity LTS version 2019.4.7f1. I am not using URP or HDRP as I do not require both. But I am using "Visual Effect Graph" which is unavoidable for my project. When I imported game4automation to my project I am facing the above issue. I also require OPCUA4UNITY for my project. Is there any solution?

Can you send us your project and I will check if we can find a way for working with visual effect praph?

I'm afraid I can't share my full project. I can provide a blank project with only game4automation & Visual Effect Graph because the same issue is showing in an empty project with only game4automation & Visual Effect Graph.

Antwort

Please share with me the blank project. Thanks!

Please share your email ID

info@game4automation.com

I've shared the project.