0
Beantwortet

Grip scripts teleports mu to a different location

Matteo vor 2 Wochen in Game4Automation Starter and Professional aktualisiert von Thomas vor 3 Tagen 1

Hi I'm having an issue with the grip script which I placed on a rotary arm on the automatic machine I'm designing, when the PLCOutputBool I use to pick the designated mu goes to true the MU that should be picked up and placed immediately teleports to a different location. My grip works just fine, but the mu will be moved on the location where it was teleported instead of attached to the gripper. I will include some pictures to better explain the issue.
In the first picture the green arrow points to the gripper and the red one to the mu.
In the second one, you can see how the mu (red arrow) is teleported to a different location immediately just as the signal linked to "Signal Pick" is true.

The pivots of the sensor linked to "part to grip", of the gripper and the pivot of the rotary arm correctly set. The Pivot of the game object representing all the automatic machine (highest in the hierarchy) is located also on the red arrow in the secon picture.

How do I fix this issue?

Thanks




Antwort

Antwort
Beantwortet

Sorry for my late response.

Grip should work. Please check how we did it in our dem model.

You can upload  your model via https://game4automation.com/send and I will check what is missing in your project.

Antwort
Beantwortet

Sorry for my late response.

Grip should work. Please check how we did it in our dem model.

You can upload  your model via https://game4automation.com/send and I will check what is missing in your project.