0
Under review

Problem with collisions

Bo Adam 2 months ago in realvirtual.io Starter and Professional updated by Support 2 months ago 6

Hello,

It's me again, I have a problem with a MU, I "spawn" This mu onto a transport surface in g4atransport. It stays in position and can be gripped by the gripper. But when the gripper places it into a warehouse (With a mesh collider) It just falls through the warehouse and floor.
Below are the warehouse settings and the carrier (MU) settings

Answer

Answer
Under review

It is hard to say what your problem is - everything should work out the box. Can you send your project with a description where the problem occurs and I will directly check in your projet.

I now get this error message, but the carrier starts as being kinematic, but that changes as soon as i start the game.

As soon as the gripper opens, the rigidbody stops being kinematic.

In Grip I found the only piece of code adressing the kinematic of the MU:

if (PlaceLoadOnMUSensor == null)
{
if (!NoPhysicsWhenPlaced)
rb.isKinematic = false;
}

Commenting out the line rb.isKinematic = false; did not work.

This feels like it is inverted as well. As NoPhysicsWhenPlaced is true, it shouldnt have phisics so rb.isKinematic should be false. Now rb.isKinematic does not change when NoPhisicsWhenPlaced is true.  

if (PlaceLoadOnMUSensor == null)

{

if (!NoPhysicsWhenPlaced)

rb.isKinematic = true;

else

rb.isKinematic = false;

}

This fixed it!

Answer
Under review

It is hard to say what your problem is - everything should work out the box. Can you send your project with a description where the problem occurs and I will directly check in your projet.